docker support问题

  1. https://www.t-firefly.com/doc/download/107.html下载了debian image,并烧录到ROC-3568-PC,成功启动
  2. 成功安装OMV和OMV-EXTRAS
  3. 使用OMV-EXTRAS安装docker失败

咨询:官方提供下载的debian image是否支持docker,
问题1,若不支持,能否提供支持版本下载?
问题2, 无支持(docker)版本下载,可否提供编译文档,用于编译支持docker的image

出错log如下图所示:

不支持,需要自己编译一个支持的内核,编译方法在维基里有:
https://wiki.t-firefly.com/zh_CN/ROC-RK3568-PC/ubuntu_manual.html#docker-zhi-chi
使用现成的docker配置文件编译一下内核,然后把boot.img烧录到板子上就行了

图片没有上传成功,log 如下:
e upgraded, e newly installed, e to remove and 8 not upgraded.
1 not fully installed or removed.
fter this operation, e B of additional disk space will be used.
Setting
insserv :
insserv :
insserv :
insserv :
Job for
up docker-ce (5:20.10.120-eædebian-buster)
script firstboot.sh: service rockchip already provided!
warning: script ‘rkisp_3A. sh’ missing LSB tags
Default-Start undefined, assuming empty start runlevel(s) for script ‘rkisp_3A. sh’
Default-Stop undefined, assuming empty stop runlevel(s) for script rkisp_3A. sh ’
docker. service failed because the control process exited with error code.
See “systemctl status docker. service” and “journalctl -xe” for details.
invoke-rc.d: initscript docker, action “start” failed.
• docker. service -
Docker Application Container Engine
Loaded :
Active:
Docs:
Process:
Main PID:
loaded (/lib/systemd/system/docker. service; enabled; vendor preset: enabled)
activating (auto-restart) (Result: exit-code) since Wed 2022-03-09 06:31:38 UTC; 17ms ago
https : //docs . docker . com
9857 Execstart=/usr/bin/dockerd -H fd://
9857 (code=exited, status-I/ FAILURE)
–containerd=/run/containerd/containerd. sock (code-exited,
status=1/FAILURE)
dpkg: error processing package docker-ce (–configure) :
installed docker-ce package post-installation script subprocess returned error exit status 1
Errors were encountered while processing:
docker-ce
Unable to fix docker install.

Liuth 发表于 2022-3-9 14:37
不支持,需要自己编译一个支持的内核,编译方法在维基里有:
https://wiki.t-firefly.com/zh_CN/ROC-RK356

你好,感谢恢复,
看到了如何开启docker支持,同时有一个编译问题,
https://wiki.t-firefly.com/zh_CN/ROC-RK3568-PC/linux_compile_gpt.html,这个(ROC3568pc)编译指南里面没有对debian编译的描述,是否可以参考其他板子的编译指南编译debian,例如:https://wiki.t-firefly.com/zh_CN/AIO-3288J/linux_compile_gpt.html

1. 已经根据(https://wiki.t-firefly.com/zh_CN … html#docker-zhi-chi)编译支持docker的boot.img:
2. 成功刷入开发板,并启动进入系统:

3. 按照如下方式安装:
sudo apt-get install -y
apt-transport-https
ca-certificates
curl
gnupg2
software-properties-common

curl -fsSL https://download.docker.com/linux/debian/gpg | sudo apt-key add -

echo “deb [arch=arm64] https://download.docker.com/linux/debian $(lsb_release -cs) stable” | sudo tee /etc/apt/sources.list.d/docker.list

sudo apt-get update
sudo apt-get upgrade -y
sudo apt-get install -y docker-ce

4. 安装失败,失败log:
firefly@firefly:~$ sudo apt-get install -y docker-ce
Reading package lists… Done
Building dependency tree
Reading state information… Done
The following additional packages will be installed:
apparmor containerd.io docker-ce-cli docker-ce-rootless-extras git git-man liberror-perl pigz
Suggested packages:
apparmor-profiles-extra apparmor-utils cgroupfs-mount | cgroup-lite gettext-base git-daemon-run
| git-daemon-sysvinit git-doc git-el git-email git-gui gitk gitweb git-cvs git-mediawiki git-svn
Recommended packages:
slirp4netns
The following NEW packages will be installed:
apparmor containerd.io docker-ce docker-ce-cli docker-ce-rootless-extras git git-man liberror-perl pigz
0 upgraded, 9 newly installed, 0 to remove and 0 not upgraded.
Need to get 82.1 MB of archives.
After this operation, 378 MB of additional disk space will be used.
Get:1 http://mirrors.aliyun.com/debian buster/main arm64 pigz arm64 2.4-1 [48.0 kB]
Get:2 http://mirrors.aliyun.com/debian buster/main arm64 apparmor arm64 2.13.2-10 [504 kB]
Get:3 https://download.docker.com/linux/debian buster/stable arm64 containerd.io arm64 1.4.13-1 [16.8 MB]
Get:4 http://mirrors.aliyun.com/debian buster/main arm64 liberror-perl all 0.17027-2 [30.9 kB]
Get:5 http://mirrors.aliyun.com/debian buster/main arm64 git-man all 1:2.20.1-2+deb10u3 [1620 kB]
Get:6 https://download.docker.com/linux/debian buster/stable arm64 docker-ce-cli arm64 5:20.10.12~3-0~debian-buster [36.4 MB]
Get:7 http://mirrors.aliyun.com/debian buster/main arm64 git arm64 1:2.20.1-2+deb10u3 [5509 kB]
Get:8 https://download.docker.com/linux/debian buster/stable arm64 docker-ce arm64 5:20.10.12~3-0~debian-buster [13.9 MB]
Get:9 https://download.docker.com/linux/debian buster/stable arm64 docker-ce-rootless-extras arm64 5:20.10.12~3-0~debian-buster [7179 kB]
Fetched 82.1 MB in 19s (4314 kB/s)
Preconfiguring packages …
Selecting previously unselected package pigz.
(Reading database … 56783 files and directories currently installed.)
Preparing to unpack …/0-pigz_2.4-1_arm64.deb …
Unpacking pigz (2.4-1) …
Selecting previously unselected package apparmor.
Preparing to unpack …/1-apparmor_2.13.2-10_arm64.deb …
Unpacking apparmor (2.13.2-10) …
Selecting previously unselected package containerd.io.
Preparing to unpack …/2-containerd.io_1.4.13-1_arm64.deb …
Unpacking containerd.io (1.4.13-1) …
Selecting previously unselected package docker-ce-cli.
Preparing to unpack …/3-docker-ce-cli_5%3a20.10.12~3-0~debian-buster_arm64.deb …
Unpacking docker-ce-cli (5:20.10.12~3-0~debian-buster) …
Selecting previously unselected package docker-ce.
Preparing to unpack …/4-docker-ce_5%3a20.10.12~3-0~debian-buster_arm64.deb …
Unpacking docker-ce (5:20.10.12~3-0~debian-buster) …
Selecting previously unselected package docker-ce-rootless-extras.
Preparing to unpack …/5-docker-ce-rootless-extras_5%3a20.10.12~3-0~debian-buster_arm64.deb …
Unpacking docker-ce-rootless-extras (5:20.10.12~3-0~debian-buster) …
Selecting previously unselected package liberror-perl.
Preparing to unpack …/6-liberror-perl_0.17027-2_all.deb …
Unpacking liberror-perl (0.17027-2) …
Selecting previously unselected package git-man.
Preparing to unpack …/7-git-man_1%3a2.20.1-2+deb10u3_all.deb …
Unpacking git-man (1:2.20.1-2+deb10u3) …
Selecting previously unselected package git.
Preparing to unpack …/8-git_1%3a2.20.1-2+deb10u3_arm64.deb …
Unpacking git (1:2.20.1-2+deb10u3) …
Setting up liberror-perl (0.17027-2) …
Setting up apparmor (2.13.2-10) …
insserv: script firstboot.sh: service rockchip already provided!
insserv: warning: script ‘rkisp_3A.sh’ missing LSB tags
insserv: Default-Start undefined, assuming empty start runlevel(s) for script rkisp_3A.sh' insserv: Default-Stop undefined, assuming empty stop runlevel(s) for script rkisp_3A.sh’
Created symlink /etc/systemd/system/sysinit.target.wants/apparmor.service → /lib/systemd/system/apparmor.service.
Setting up containerd.io (1.4.13-1) …
Created symlink /etc/systemd/system/multi-user.target.wants/containerd.service → /lib/systemd/system/containerd.service.
Setting up docker-ce-cli (5:20.10.12~3-0~debian-buster) …
Setting up pigz (2.4-1) …
Setting up git-man (1:2.20.1-2+deb10u3) …
Setting up docker-ce-rootless-extras (5:20.10.12~3-0~debian-buster) …
Setting up docker-ce (5:20.10.12~3-0~debian-buster) …
Created symlink /etc/systemd/system/multi-user.target.wants/docker.service → /lib/systemd/system/docker.service.
Created symlink /etc/systemd/system/sockets.target.wants/docker.socket → /lib/systemd/system/docker.socket.
insserv: script firstboot.sh: service rockchip already provided!
insserv: warning: script ‘rkisp_3A.sh’ missing LSB tags
insserv: Default-Start undefined, assuming empty start runlevel(s) for script rkisp_3A.sh' insserv: Default-Stop undefined, assuming empty stop runlevel(s) for script rkisp_3A.sh’
Job for docker.service failed because the control process exited with error code.
See “systemctl status docker.service” and “journalctl -xe” for details.
invoke-rc.d: initscript docker, action “start” failed.
● docker.service - Docker Application Container Engine
Loaded: loaded (/lib/systemd/system/docker.service; enabled; vendor preset: enabled)
Active: activating (auto-restart) (Result: exit-code) since Thu 2022-03-10 06:45:47 UTC; 18ms ago
Docs: https://docs.docker.com
Process: 4220 ExecStart=/usr/bin/dockerd -H fd:// --containerd=/run/containerd/containerd.sock (code=exited, status=1/FAILURE)
Main PID: 4220 (code=exited, status=1/FAILURE)
dpkg: error processing package docker-ce (–configure):
installed docker-ce package post-installation script subprocess returned error exit status 1
Setting up git (1:2.20.1-2+deb10u3) …
Processing triggers for systemd (241-7~deb10u10firefly1) …
Errors were encountered while processing:
docker-ce
E: Sub-process /usr/bin/dpkg returned an error code (1)

debian和ubuntu只有文件系统区别,所以编译方法是一样的,按照356x ubuntu编译方法就行

用检测脚本文件在你板子上运行一下,看一下配置有没有生效
https://dev.t-firefly.com/thread-115083-1-1.html

目前状态还是无法在debin版系统上安装dockers
已使用docker check脚本,依赖的必需选项都已开启,
使用的组合:
开启docker支持build的kernel+firefly debin rootfs 无法安装
开启docker支持build的kernel+firefly ubuntu rootfs 可以安装
开启docker支持build的kernel+debin rootfs(arm64)存在驱动问题,无法测试
开启docker支持build的kernel+build rockchip debin rootfs(最新) 无法安装

记录供大家参考,前两个组合推测问题可能出现在rootfs上,所以进行了后面两组测试,但是从结果看,和rootfs又似乎无关

你那不是安装失败,已经安装好了,是 docker 服务启动失败,目前发现debian使用了nftables替代了iptabels作为默认

在debian里面用root权限执行下面的4条命令

# update-alternatives --set iptables /usr/sbin/iptables-legacy
# update-alternatives --set ip6tables /usr/sbin/ip6tables-legacy
# update-alternatives --set arptables /usr/sbin/arptables-legacy
# update-alternatives --set ebtables /usr/sbin/ebtables-legacy

然后重启看看docker能不能运行

Liuth 发表于 2022-3-22 17:48
你那不是安装失败,已经安装好了,是 docker 服务启动失败,目前发现debian使用了nftables替代了iptabels作 …

感谢感谢 确实解决了问题 描述准确 是安装成功了没运行起来

要先编译内核,不过维基编译教程访问不了